Vitelity Incident Notification - Portal Degraded Performance

Incident Report for Vitelity

Update

We are continuing to monitor for any further issues.
Posted Apr 14, 2026 - 11:13 CDT

Monitoring

A fix has been implemented and we are monitoring.
Posted Apr 13, 2026 - 17:03 CDT

Identified

Vitelity is investigating an incident that is causing portal issues with both the customer portal and viewmyfax.com. All appropriate teams are actively engaged. We will continue to keep status.vitelity.com updated with the progress details.
Posted Apr 13, 2026 - 16:45 CDT
This incident affects: Customer Portal (Customer Portal) and Fax Services (View My Fax Portal).