Vitelity Outage Notification // Parent Case #01314393 // Fax Inbound & Outbound Delayed
Incident Report for Vitelity
Resolved
This incident has been resolved. If you believe you are missing any faxes, please create a support ticket with the details of your fax (Source, Destination, Date, Time, Time-zone) for our support team to investigate.
Posted Mar 11, 2024 - 17:16 CDT
Monitoring
A fix has been implemented and we are seeing faxes being successfully delivered now. We will continue to monitor until the fax queue has cleared.
Posted Mar 11, 2024 - 16:33 CDT
Identified
Vitelity teams are currently investigating reports of fax impairments to all faxing services (inbound & outbound). All appropriate teams are actively engaged. We will continue to keep status.vitelity.com updated with the progress details.

Should you need to contact us or open a new case, please call +1-888-898-4835 or log into your portal and submit a support ticket.

Please do not respond to this email address as it is not monitored.

Thank you,
Vitelity Network Operations Center
Posted Mar 11, 2024 - 15:00 CDT
This incident affected: Fax Services (vFax, Fax Enabled Device, View My Fax Portal).