Vitelity-3CX Advisory

Incident Report for Vitelity

Update

We are continuing to monitor for any further issues.
Posted Jun 24, 2026 - 11:41 CDT

Monitoring

Vitelity has become aware of customers using an updated version of 3CX (3CX Version 20, Update 9 RC4, Build 20.0.9.987 and later) having issues receiving inbound calls from 66.241.96.90, our inbound SBC cluster. If you are affected and using one of these versions, you may want to whitelist 66.241.96.90 and/or disable the Global Blocklist feature built into 3CX to restore service. If you have any questions, please feel free to reach out at 888 898 4835 or open a support ticket.
Posted Jun 24, 2026 - 11:40 CDT
This incident affects: SIP Trunking (Inbound Calling).