Vitelity Outage Notification // Parent Case #01446880 // Inbound & Outbound Call Failures

Incident Report for Vitelity

Resolved

This incident has been confirmed resolved. An adjustment was made which restored call traffic as well as user portal accessibility. After intensive testing and monitoring, we can confirm all services are operational at this time. If you experience any further issue, please reach out to our technical support teams.

Should you need to contact us or open a new case, please call +1-888-898-4835 or log into your portal and submit a support ticket.

Please do not respond to this email address as it is not monitored.

Thank you,
Vitelity Network Operations Center
Posted Feb 27, 2025 - 09:21 CST

Monitoring

A fix has been implemented, and we are seeing call traffic returning to normal levels. We are closely monitoring the situation to ensure continued stability. Our teams remain engaged, and we will provide further updates as needed.

Thank you for your patience and understanding. If you continue to experience any issues, please call +1-888-898-4835 or log into your portal and submit a support ticket.

Please do not respond to this email address as it is not monitored.

Thank you,
Vitelity Network Operations Center
Posted Feb 26, 2025 - 14:54 CST

Update

We are actively investigating the issue affecting calling and registration. Our teams remain fully engaged and are continuing to analyze all possible causes to ensure a swift resolution.

We will provide updates here as more information becomes available. Thank you for your continued patience.
Posted Feb 26, 2025 - 14:30 CST

Investigating

Vitelity teams are currently investigating reports of inbound and outbound call failures for some customers. All appropriate teams are actively engaged. We will continue to keep status.vitelity.com updated with the progress details.

Should you need to contact us or open a new case, please call +1-888-898-4835 or log into your portal and submit a support ticket.

Please do not respond to this email address as it is not monitored.

Thank you,
Vitelity Network Operations Center
Posted Feb 26, 2025 - 13:21 CST
This incident affected: SIP Trunking (Inbound Calling, Outbound Calling).