Vitelity Outage Notification // Parent Case #01034918 // Call Completion Failures
Incident Report for Vitelity
Resolved
This incident has been confirmed resolved. An adjustment was made which restored call traffic as well as user portal accessibility. After intensive testing and monitoring, we can confirm all services are operational at this time. If you experience any further issue, please reach out to our technical support teams.

Should you need to contact us or open a new case, please call +1-888-898-4835 or log into your portal and submit a support ticket.

Please do not respond to this email address as it is not monitored.

Thank you,
Vitelity Network Operations Center
Posted May 12, 2022 - 11:32 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2022 - 08:50 CDT
Update
We are continuing to investigate this issue.
Posted May 12, 2022 - 08:14 CDT
Update
We are continuing to investigate this issue.
Posted May 12, 2022 - 08:13 CDT
Investigating
Vitelity teams are currently investigating reports o call completion failures as well as portal accessibility for most customers. All appropriate teams are actively engaged. We will continue to keep status.vitelity.com updated with the progress details.

Should you need to contact us or open a new case, please call +1-888-898-4835 or log into your portal and submit a support ticket.

Please do not respond to this email address as it is not monitored.

Thank you,
Vitelity Network Operations Center
Posted May 12, 2022 - 08:11 CDT
This incident affected: Customer Portal (Customer Portal), SIP Trunking (Inbound Calling, Outbound Calling), and Fax Services (vFax, View My Fax Portal).